Gtir Motorsport club

Welcome to the largest Nissan Pulsar & Sunny GTI-R Forum. Masses of info, friendly members, cars for sale, lots of spares. Best forum on the net by far. Everything your gtir needs is here.


You are not connected. Please login or register

Gtir Motorsport club » Tech room » Help and Advice » Runnig rich

Runnig rich

View previous topic View next topic Go down  Message [Page 1 of 1]

1 Runnig rich on 5th February 2014, 6:28 pm

Gaz GTiR

avatar
I had an old topic about this but cant find it?

Anyway I had a problem where I was running realy rich on my wideband... 10.9 on idle & 11.4 - 12.5 off boost & 10.9 on boost @WOT. But now ive put a RA gearbox on instead of the RB it seems to be a little more rich? Maybe cos revs arnt as high & gear ratios are longer?

Where idealy I should be around 14.5 on idle & 14s - 16s off boost & 11.5 - 12.4 on boost @WOT

So for some reason im running masivley rich right threw the rev range? Ive spoke to Ed at fusion a while back & he reckons fuel preasure is to high? But now ive thought about it im only running standard FPR.

So has anyone got any ideas what it could be? The car was mapped 3 years ago by Ed & the fueling graph is perfect & where it should be. So something else has to be causing this?

2 Re: Runnig rich on 5th February 2014, 6:34 pm

GTI-R US

avatar
Management
Management
vacuum leak
boost leak
dodgy injectors
in-correct ignition timing

should really be around 16 at idle as you don't need much fuel
light partial load should also be around stoich
as boost starts should then linearly drop to around 11s or high 10s on full boost

http://www.gti-r-us.co.uk www.force500.com

3 Re: Runnig rich on 5th February 2014, 7:01 pm

Gaz GTiR

avatar
Checked vac lines & cant see any leaks. Ive got good vacuem according to my AVCR -350

Checked all boost pipes when I did gearbox at weekend, But suppose there could be a leak at inlet but car runs fine?

Timing is at 20 degrees

I had injectoers cleaned & tested a few years back but maybe they could of broken down? Ill get them tested again.

4 Re: Runnig rich on 5th February 2014, 7:10 pm

Stu

avatar
Admin
Admin
Afm? It's been standing for a while so could have damp in it? Or corrosion?

http://www.j10-meets.co.uk

5 Re: Runnig rich on 5th February 2014, 7:12 pm

Gaz GTiR

avatar
Yeh but it was like it before I blew the box? Could re'earthing it help?

6 Re: Runnig rich on 6th February 2014, 2:05 pm

GTI-R US

avatar
Management
Management
could possibly be the maf but somehow I very much doubt it as youll have problems with hesitation and stuttering as car comes on to boost.

wont hurt to splice into the earth though and run another wire to a good ground on the body

other things to check are the ecu temp sensor, inlet air control valve if your 100% positive everything else is as it should be

http://www.gti-r-us.co.uk www.force500.com

7 Re: Runnig rich on 6th February 2014, 3:12 pm

Gaz GTiR

avatar
Ok, sorry for sounding thick but where abouts is the ECU temp senser & inlet air control valve positioned?

8 Re: Runnig rich on 6th February 2014, 3:34 pm

GTI-R US

avatar
Management
Management
ecu temp sensor is the one on back of throttle bodies near brake master cylinder
iacc valve is right at the back of throttle bodies near the vacuum chamber pot

http://www.gti-r-us.co.uk www.force500.com

9 Re: Runnig rich on 6th February 2014, 3:55 pm

Gaz GTiR

avatar
Cheers Bob, ill take a look

10 Re: Runnig rich on 23rd July 2014, 10:34 pm

grim_d

avatar
Sorry to dig up and old thread but did you sort this out gaz? Might shed some light on my rich running.

Sponsored content


View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum