Gtir Motorsport club

Welcome to the largest Nissan Pulsar & Sunny GTI-R Forum. Masses of info, friendly members, cars for sale, lots of spares. Best forum on the net by far. Everything your gtir needs is here.


You are not connected. Please login or register

Gtir Motorsport club » Tech room » Help and Advice » Lagging in power

Lagging in power

View previous topic View next topic Go down  Message [Page 1 of 1]

1 Lagging in power on 23rd August 2015, 10:00 am

Ryds


Hi all
Got my pulsar at last. It's been sat for about 2 years but on idle sounds good no knocking or smoke. Went out for a short drive to see how she is and she lags as if she can't breath. Going to give a full service has anyone got any ideas on what might be the issue.

2 Re: Lagging in power on 23rd August 2015, 10:33 am

pulsar23


What air filter you using? Obviously check breather pipes etc... General service can work miracles!!

3 Re: Lagging in power on 23rd August 2015, 10:57 am

Stu

avatar
Admin
Admin
Afm might need a clean.
I take it after 2 years of standing you have filled the fuel up. Old fuel will make the car run shite.


_________________
Back againTwisted Evil
http://www.j10-meets.co.uk

4 Re: Lagging in power on 23rd August 2015, 11:03 am

Ryds


Soon as I do the service and add new fuel I'll let you know how she is running thanks.

5 Re: Lagging in power on 23rd August 2015, 2:19 pm

johnny gtir

avatar
moderator
moderator
Personslly i can not belive you would be testing a car out if it's sat for two year without fully servicing and checking every last bit of it if it's sat. Change all fluids ,plugs check pipes two year clean afm and check dizzy etc lots to do

6 Re: Lagging in power on 23rd August 2015, 4:11 pm

Ryds


I know what your saying Johnny and I will be doing all that before hitting the road. Thanks for the advice.

7 Re: Lagging in power on 23rd August 2015, 8:20 pm

johnny gtir

avatar
moderator
moderator
Re read that sounds harsh never ment it to come across like that just mean sometimes you leave them 5 mins and they need checked just don't want something simple costing you your engine

8 Re: Lagging in power on 23rd August 2015, 8:45 pm

Ryds


Thanks I will do my best to get her right as it will be pride and joy now owning one again. I'll keep you posted on here on my progress and asking if I need any other help. Thanks again.

9 Re: Lagging in power on 26th October 2015, 8:02 pm

Gostek

avatar
Events Organiser
Events Organiser
Right so I've had look on it too got rid of misfire on boost (dizzy) sorted out vacc piping etc, but car is still low on compression on cyl no 4
no1 to 3 150psi no4 75 psi we've put some penetrator oil left it for couple of days and no change. Put some oil down the bore it rise comp to 125 psi warmed car up (stopped smoking etc) and comp back to 75 psi. There is no smoke or knock etc from top or bottom car takes that extra turn to start drives ok when cold not so ok when warmed up. Another thing which I've noticed oil temp is going up very quickly after 1mile it's around 90 deg and there is rust in coolant.
So have you guys got any suggestions before I'll take head off??


_________________

10 Re: Lagging in power on 26th October 2015, 8:22 pm

Gostek

avatar
Events Organiser
Events Organiser


_________________

Sponsored content


View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum