Gtir Motorsport club

Welcome to the largest Nissan Pulsar & Sunny GTI-R Forum. Masses of info, friendly members, cars for sale, lots of spares. Best forum on the net by far. Everything your gtir needs is here.


You are not connected. Please login or register

Gtir Motorsport club » Tech room » Help and Advice » Speedo cluster question

Speedo cluster question

View previous topic View next topic Go down  Message [Page 1 of 1]

1 Speedo cluster question on 2nd November 2016, 10:39 am

DRC

avatar
Hi guys since I have had the R the speedo is very inaccurate giving underand over readings ( +\- 20mph at speed and has been converted to mph ) also the temp gauge only moves off the needle at 82c and and never gets near its normal area of operation . I have checked both these issues against the read out on the FC commander unit .

Everything else works fine on the unit.
Is it anything anyone has heard of or shall I just get a new unit and see what happens.
Cheers

2 Re: Speedo cluster question on 2nd November 2016, 2:30 pm

Whytie

avatar
Do you have aftermarket dials?

3 Re: Speedo cluster question on 2nd November 2016, 6:18 pm

johnny gtir

avatar
moderator
moderator
As above or just age related lots of clocks are messed up or been interfeared with

4 Re: Speedo cluster question on 3rd November 2016, 8:39 am

johnboy

avatar

First thing I'd do is temporary disconnect the mph converter and see if the speedo is Ok without it. I'd always blame aftermarket stuff first.. Has it got white dials? Often damaged when these are put on.

Sponsored content


View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum