Gtir Motorsport club

Welcome to the largest Nissan Pulsar & Sunny GTI-R Forum. Masses of info, friendly members, cars for sale, lots of spares. Best forum on the net by far. Everything your gtir needs is here.


You are not connected. Please login or register

Gtir Motorsport club » Tech room » Help and Advice » No boost

No boost

Go down  Message [Page 1 of 1]

1 No boost on 4th September 2018, 7:13 pm

James


Hi guys,

Picked up a 91 with 77K and on the way home realized the car was no longer boosting over 0 on the stock boost gauge. Car obviously feels like it too. Checked all the lines and pulled off the intercooler, nothing obvious leaking or disconnected. Haven't checked lines behind the intake manifold (dont have a smoker). I can hear the turbo quietly "spooling" with partial throttle but only to 0 psi so that leads me to believe it's not seized. I've read that the Watergate actuator rod clips come off commonly, but dont have any easy way to check without pulling off shield and piping.
Car doesn't really feel like there's a giant vacuum leak but I am definitely out of tune with 90's cars. Idles fine, runs good for being NA. Also at idle we unplugged a couple vacuum lines (to boost gauge) to create our own vacuum line and idle conditions didn't even flinch. Made no difference.

Any advice?

Thank you!

2 Re: No boost on 4th September 2018, 10:02 pm

nomad

avatar
Admin
Admin
Have you tried running unlimited BOOST? What set up do you have ?


_________________
"Official post whore" and all round superhero....

3 Re: No boost on 4th September 2018, 10:43 pm

James


@nomad wrote:Have you tried running unlimited BOOST? What set up do you have ?

Stock

Sent from Topic'it App

4 Re: No boost on 5th September 2018, 1:01 am

James


Pulled off the turbo side of the intercooler hose today and had a bit of oil in it, seems like the turbo might of crapped the bed.

Anyone have recommendations for rebuild kits?

Sent from Topic'it App

5 Re: No boost on 5th September 2018, 9:05 am

mike74

avatar
A little oil in the inlet is normal...if its dripping out then not so normal.

I used these guys last year:
https://www.turborebuild.co.uk/

They replaced the actual bearing cartridge for new, new 360° thrust bearing, a general refresh with new bearings and seals and an uprated compressor wheel for just shy of £300. Turnaround is a matter of days too Very Happy
Its still holding up fine and has been running 1.2 bar daily

6 Re: No boost on 5th September 2018, 12:35 pm

James


@mike74 wrote:A little oil in the inlet is normal...if its dripping out then not so normal.



They replaced the actual bearing cartridge for new, new 360° thrust bearing, a general refresh with new bearings and seals and an uprated compressor wheel for just shy of £300.

Yeah it was a nice little puddle in there, I'm in the US so I'll explore some local turbo rebuilders. You just dropped off the turbo and that was it?

Sent from Topic'it App

7 Re: No boost on 5th September 2018, 1:10 pm

mike74

avatar
Ah, maybe not quite such a handy link for you then lol!
All I had to do was post it to them then once they had a look, they gave me a phone to discuss what I wanted to do

Sponsored content


Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum