Gtir Motorsport club
Would you like to react to this message? Create an account in a few clicks or log in to continue.
Gtir Motorsport club

Welcome to the largest Nissan Pulsar & Sunny GTI-R Forum. Masses of info, friendly members, cars for sale, lots of spares. Best forum on the net by far. Everything your gtir needs is here.


You are not connected. Please login or register

Gtir Motorsport club » Tech room » Help and Advice » ECU temp sensor

ECU temp sensor

Go down  Message [Page 1 of 1]

1ECU temp sensor Empty ECU temp sensor on 15th June 2015, 10:31 pm

Gaz GTiR

Gaz GTiR
Right car has been running rich for a while now & spike pulled the fuel map up via nistune at the last RR day & fuel map was ok... so ive checked for vac leaks & vac is good at -460 on avcr at idle.. Car holds boost at 1bar perfectly so cant see there being a boost leak & also tried different mafs...

After speaking to Bob he thinks it could be ECU temp sencor that fooked & telling the ECU the cars cold even when hot, as the afrs on idle dot change from cold start up to when its hot!

Tried to change ECU temp sensor today & can get to it with a 19mm socket & UJ... But theres no room to get your hand in without removing mastercylender... So im struggling to remove the plug & I don't want to pull on it as I don't want to damage wiring! Its like a injector plug with the metal paper clip thingy Rolling Eyes  Any ideas how to pop it off?

Tried a thin long screwdriver to tet the clip off but still no joy

2ECU temp sensor Empty Re: ECU temp sensor on 16th June 2015, 12:43 am

grim_d

grim_d
Persistence and lots of manual dexterity.  Keep at it and don't get frustrated.

Changed both temp sensors last year without removing anything else and I have enormous Gorilla paws, use the likes of a pick to get the clip off and fish it out with needle nose pliers.

As for getting the sensor out I'm pretty sure I wound it out with a socket, a bit of careful fingertip action will get it back in, it's not an easy job but it is possible in situ, depending on your engine bay config and your arm length you may be able to reach around (ooh-err) from underneath the plenum.

Getting the plug and clip back on after is probably the hardest part.

Good luck.

3ECU temp sensor Empty Re: ECU temp sensor on 16th June 2015, 8:30 am

Thermal

Thermal
I jacked up the car, (with axle stands) and got at it from underneath, I think I also unscrewed the oil filter to help access. But I did use a big jack.

4ECU temp sensor Empty Re: ECU temp sensor on 16th June 2015, 9:45 am

grim_d

grim_d
That would also work exhaust dependent, I would of had to take my mid pipe off.

5ECU temp sensor Empty Re: ECU temp sensor on 16th June 2015, 3:46 pm

Gaz GTiR

Gaz GTiR
Right changed the ECU temp sensor & its made it a tiny bit better on wideband... Instead of idling @ 10.9 its now idling @ 11.3... And cruising off boost in high 12s low 13s... On boost @WOT still the same 10.9 low 11s... Not perfect I know

I would say its the map but spike pulled the fuel map up a while back & it was saying it was 14.5 at idle which is about right! but obv somethings knocking it out?

Like I say ive also tryed different mafs & checked for vac/boost leaks & all seems ok.

It has got a 200sx FPR on but Ed at fusion put that on when it was mapped, so pretty sure there the same pressure! Ive got another Pulsar FPR now so ill try that tomorrow...

Its just baffling me how the AFR's arnt changing from cold start/idle to hot idle... There staying the same! scratch

6ECU temp sensor Empty Re: ECU temp sensor on 16th June 2015, 4:25 pm

Gaz GTiR

Gaz GTiR
Just tryed FPR... No different, i give up

7ECU temp sensor Empty Re: ECU temp sensor on 16th June 2015, 5:09 pm

Spark plug spike

Spark plug spike
I will bring the laptop with Nistune to the meet and have another look at it for you?

8ECU temp sensor Empty Re: ECU temp sensor on 16th June 2015, 5:14 pm

Gaz GTiR

Gaz GTiR
@Spark plug spike wrote:I will bring the laptop with Nistune to the meet and have another look at it for you?

Cheers spike Smile

9ECU temp sensor Empty Re: ECU temp sensor on 16th June 2015, 10:57 pm

johnny gtir

johnny gtir
moderator
moderator
I would have said a few things to check inc  the full map things like the tps been well out surly alters things

10ECU temp sensor Empty Re: ECU temp sensor on 17th June 2015, 10:36 am

Gaz GTiR

Gaz GTiR
Yeh maybe johnny, but was told aslong as TPS is 0.45 or below its ok. mines at 0.10 but cant adjust it till I get it remapped as it alters the ign timing & if I put timing to 20 degrees again after adjusting TPS it will mess the map up, so got to leave TPS at min

Sponsored content


Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum