Gtir Motorsport club
Would you like to react to this message? Create an account in a few clicks or log in to continue.
Gtir Motorsport club

Welcome to the largest Nissan Pulsar & Sunny GTI-R Forum. Masses of info, friendly members, cars for sale, lots of spares. Best forum on the net by far. Everything your gtir needs is here.


You are not connected. Please login or register

Gtir Motorsport club » Tech room » Help and Advice » Cobra Alarm Problems

Cobra Alarm Problems

Go down  Message [Page 1 of 1]

1Cobra Alarm Problems Empty Cobra Alarm Problems on 16th May 2016, 4:54 pm

joetheeskimo

joetheeskimo
Hi All

Didnt have any issues with my cobra alarm before but now having some issues. When you the car is locked the LED on the dash flases red, SHowing the immoboliser is immobolised.
When you unlock the car the LED goes out, however when i put the key in the ignition and turn nothing happens, i hear a click but car does not start. Electric windows dont work which i assume 12V is not being allowed to get past the relay.

When you turn the key i can hear clicking, i can feel one of the three relays near the internal fuse box is clicking.

Also when you have unlocked the car with the key in the ignition you can hear the Cobra immoboliser is detactivated by hearing a beaping noise.
As the cobra immoboliser seems to be activating and deactivating i guess i can elimnate this from the problem.

Any ideas on this.

Do cobra alarms have thier relay someone in the car etc.
Has any one else had issues like this before.

Thanks

2Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 16th May 2016, 9:10 pm

joetheeskimo

joetheeskimo
Does any one have a schematic for the interior relays. I want to check all of them tomorrow to ensure they are working ok.
I don't think it can be the alarm as the immobiliser deactivates when required. Just don't seem to get any power to the accessory items or able to start the car

3Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 16th May 2016, 9:16 pm

johnny gtir

johnny gtir
moderator
moderator
You got dash lights etc ?

4Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 17th May 2016, 8:33 am

Cosmic73

Cosmic73
first things first, is your battery fully charged?

5Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 17th May 2016, 10:51 am

joetheeskimo

joetheeskimo
@Cosmic73 wrote:first things first, is your battery fully charged?

Battery is fully charged. Made sure of that. kept it on charge all of yesterday. I was able to get it started and wound down the window, but turned it off and tried to start it again and wouldn't start and now cant do the window the up.

6Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 17th May 2016, 3:00 pm

Mr B

Mr B
gtir technician
gtir technician
One of the 3 blue relays bad or the green one near the ecu harness plug ... !
those relays used on loads of nissans so local beakers could be source of handful test relays for cheap simple testing/fix .

7Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 17th May 2016, 3:38 pm

Cosmic73

Cosmic73
If you have a multimeter you can also test the relay?
Could the clicking be the starter motor solenoid not engaging?

8Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 17th May 2016, 4:52 pm

joetheeskimo

joetheeskimo
@Cosmic73 wrote:If you have a multimeter you can also test the relay?
Could the clicking be the starter motor solenoid not engaging?

The clicking is defintly coming from the two bottom blue relays internally just re-checked that.

9Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 17th May 2016, 4:53 pm

joetheeskimo

joetheeskimo
@johnny gtir wrote:You got dash lights etc ?

No dash lights at all. Electric mirrors, electric windows dont work etc.

WHere is the green relay located. Im going to check all the relays tomorrow.

10Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 17th May 2016, 5:18 pm

Mr B

Mr B
gtir technician
gtir technician
Green relay is on loom behind centre console near the grey plug
this one an ignition relay
Could be blue ones, possibly middle one .
Normally is relays for your type issue or even ignition barrel switch itself is possible

Had a post some time back with same sort issue and changing relay was the fix, can't find post though as would of been useful ...

11Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 17th May 2016, 5:33 pm

joetheeskimo

joetheeskimo
@Mr B wrote:Green relay is on loom behind centre console near the grey plug
this one an ignition relay
Could be blue ones, possibly middle one .
Normally is relays for your type issue or even ignition barrel switch itself is possible

Had a post some time back with same sort issue and changing relay was the fix, can't find post though as would of been useful ...

Just foind it thanks, I will test relays tomorrow.
How do I go about testing the ignition barrel. There is there a schematic any where for it.

12Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 17th May 2016, 5:48 pm

Mr B

Mr B
gtir technician
gtir technician
Green relay is ignition/ecu I think .
The manual will have wiring for ignition switch.
Lots of other things it could be but those relays do seem play up a lot at the R's age, check for bodgy wiring too and also another ignition relay in o/s engine bay fuse box .

13Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 17th May 2016, 7:12 pm

joetheeskimo

joetheeskimo
Just connected all the interior relays up to 12V and all were clicking happy. I didnt check the continutity of the switch though when energised so i will do this tomorrow but so far it looks like they all switch when energised.

I noticed when i turn the key the two bottom relays seem to click (accessory and blower relays) but the ignition doesnt but if im not mistaken they all share the same 12V and GND source.

14Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 17th May 2016, 7:43 pm

johnny gtir

johnny gtir
moderator
moderator
Is your battery in the front standard position and cables etc ?

15Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 17th May 2016, 7:51 pm

joetheeskimo

joetheeskimo
@johnny gtir wrote:Is your battery in the front standard position and cables etc ?

No its inside. Power cable just ran to the engine bay to join original power cable.
It's been working fine now it's not.

16Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 17th May 2016, 11:19 pm

Stu

Stu
Admin
Admin
Have you checked the square fuses in the fuse box inside engine bay passenger side inner wing?


_________________
Back againTwisted Evil
http://www.j10-meets.co.uk

17Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 18th May 2016, 7:51 am

joetheeskimo

joetheeskimo
Just tested continuity of all relays. All interior relays (including green ECU) switch OK

Power applied to terminals 1 & 2, Terminals 3 and 5 connect.
Power removed from terminals 1 & 2, Terminals 3 and 5 isolated.

I will call cobra today to see if there is a way i can check immobilizer.

If accessory and blower relays click when the ignition is switched and the ignition relay doesn't there must be no power getting to the relay.

What should i check next?

18Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 18th May 2016, 11:07 am

Mr B

Mr B
gtir technician
gtir technician
Has this fault been intermittent ?
What if any elecs will work when ignition on ?
Have you checked voltage to original engine cable & feed to fuse box
Earthing for battery
engine bay ignition relay & fuses
ignition barrel & wiring to back of it .

19Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 18th May 2016, 11:10 am

joetheeskimo

joetheeskimo
@Mr B wrote:Has this fault been intermittent ?
What if any elecs will work when ignition on ?
Have you checked voltage to original engine cable & feed to fuse box
Earthing for battery
engine bay ignition relay & fuses
ignition barrel & wiring to back of it .

Just contacted Cobra, They believe the issue is with the immobilizer unit. The immobilizer unit connects into the ignition barrel via two wires, they have said if i disconnect the immobilizer and connect the barrel back up to original connector and try and start the car. if it starts then the fault is with the cobra immobilizer.

20Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 18th May 2016, 7:12 pm

joetheeskimo

joetheeskimo
Problem sorted. Measured the voltage at the cobra immobiliser and there was no voltage so it was the cobra causing the issue. So I've now removed it and reconnected the old wiring. Still have the alarm just not the immobiliser

21Cobra Alarm Problems Empty Re: Cobra Alarm Problems on 18th May 2016, 7:37 pm

johnny gtir

johnny gtir
moderator
moderator
Good stuff people winge alarms n immobilisers cause hasel rip them out but I still say anything to slow them down stop them pinching your R is worth the odd bit of hasel to the owner

Sponsored content


Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum